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This guide will walk you through how to change, add, and remove sections of the homepage on
your website.

NOTE: This guide will assume you've already gone through the “Creating Events in New
Sitecore” guide. It covers creating folders, uploading files, renaming items, etc.

If you have any issues or questions, please contact us at PRL Helpdesk.
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Identify Homepage Sections

® Open Today 8:30 am - 4:30 pm ~  Search by: catalogue v Search Q

Key Dates
November 11, 2023 h K_@y Dates

Parkland Regional Library System

Remembrance Day

Welcome to Parkland
Regional Library
System

Parkland was the first regional library in Alberta, created in 1959.

b Banner

Special Features
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Cozy Romance and Mystery

The island villa Cinnamon twisted
Morgan, Sarah (Romance fiction writer), Bolton, Ginger, author.
author.

How to book a murder Between a wok and a dead
place
Kuhn, Cynthia, 1965- author. Budewitz, Leslie, author.

Alberta Wide Borrowing

You can return barrowed materials to any participating library and it will be
sent back to its home library at no charge.

$

Support The Library

Donate today and help ensure that the library continues to evolve to meet
the needs of our community.

Donate »

Book:

Carousel

e
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Upload Images

You might have already uploaded images for your events. In order to keep things organized,
we're going to keep images used for the website in a different section. The main section is under

Website Images, in your Library’'s folder.

4 & Content
#; Home
4 [ ParklandRegionallibrary
4 3 PRL
b # Home
4 7 Media
¥ | Creator Libraries
b ] Images
4 ] Website Images
4 ] Olds

-l| ] Website

» [l Library of Things

» 2 Donate
¥ ] Meeting Rooms
f 2022 Annual Report Graphic

== hyutton (3)

You'll want to put your images somewhere inside here. You could create subfolders for each

feature (banner images, special feature images, etc.), if you'd like.
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Homepage Banner
For the homepage banner, you can change the image, heading, and body.

Didsbury Municipal - "=
Library /m

The Didsbury Municipal Library strives to be the heart of our community, where all
come to discover, learn and connect.

LINK¢ so— Contact Us

Title
To begin editing the Homepage Banner, navigate to the one belonging to your library. Here's an
example using Olds:

4 & Contert
#i Home
4 [ ParklandRegionallibrary
4 [ PRL
P & Home
b Media
4 Data

&

b i Events

[

@ Homepage Banners

Olds
b {2 Festured Events

b Key Dates

b {1 Special Features

» i Tabbed Book Listings
» {2 Two Cards
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You'll need to click “Lock and Edit” at the top to enable editing.

You must lock this item before you can edit it.
To lock this item, click Edit on the Home tab.
Lock and Edit

The four fields to take note of here are Heading, Body, Link, and Background Image.

Heading

This is currently set to your library name. You can change this to reflect the image, current on-
goings, or the link created below.

Body

Body:

Show editor Suggest fix Edit HTML

Welcome!

This is what was displayed at launch. To change it, double click in the white box or click “Show
editor.”

Change and style the text as desired. Probably best not to include hyperlinks or anything fancy.

When you're finished, click the blue Accept button at the bottom right.
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Link
We can add a link to the banner.

These are the three main functions for this feature:

Link:

Insert link nsert media link Insert external link Insert anchor Insert emnai Insert JavaScript Follow

Insert Link
Add a link to a Sitecore content page. This window will appear:

Insert Link

Sitecore Items

Email link

Insert Sitecore Item

4 (g sitecore

4 & Content
) Home
4 [ ParklandRegionalLibrary
4 [{] FRL
4 4 Home
4 g Ouds
4 ' AboutUs
» £ Advocacy
» o] Annual Report
» | Board
» ;| ContactUs
» | Employment
» £ Fees
» £ Guiding Principles
¥ ' Our History
¥ [ Volunteer Opportunities

Cancel

Open up the tree until you find the page you'd like to link to. When you click on the page, this

will appear:
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Link Details

=

Itern Name:  Advocacy

Description:

Target:

Active Browser ~

Make sure to add a Description as that is what will be displayed on the webpage link. When
you're done, click the blue Insert button at the bottom.

External Link
Use this option to link to a website page outside of Sitecore. When you click the function, this
window will appear:

Insert External Link

Enter the URL for the external website that you want to insert a link to
and specify any additional properties for the link.

Link description:

URL: Test

Target window: Active browser w
Custom:
Style class:

Alternate text:

Insert Cancel

The two sections you need to fill out are Link description and URL. Link description is the text
that will appear on the homepage banner. URL is the address for the website. Once you've
entered both of those, click the blue Insert button.

Clear
This simply removes any information contained within the Link field.
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Background Image
This is where we set the image that displays behind the text.

Background Image [standard value]:

Brawsel Properties Open media library Refresh

This media item has no details.

Browse
Click here to open the media library. Then, click the Tree view at the top right.

Select Media

Upload media

Media

All image files

Media folder: /media library
lect a file to preview

Recently uploaded images

Recently uploaded videos

Recently uploaded by me

——

ckberry

Android Tablet Android Tablet_land... Bla

d ]

Feature Phone HD TV

Cancel
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Media folder: /media library

4 | Media Library
b ] Images
# [ Creator Libraries
4 "] Website Images
4 7] Olds
4 -] Website
» [l Library of Things
» 2] Donate
» ] Meeting Rooms
i 2022 Annual Report Graphic
== hutton (3)
== button_sign-up-today
B Final 20232025 Plan of Service |

== Renew

Here, you should see something like the above. Navigate through the tree until you find your
image. Click the blue Select button at the bottom right. You should now see the image in the
Background Image field.

Once the Heading, Body, Link, and/or Background Image have been set, you need to Check In
the item.

HOME NAVIGATE REVIEW PUBLISH VERSIONS MY TOOLBAR

I-:‘ RE- @ [g D‘ You have locked this item. i'ﬁ_]@

Save Spelling Markup  Validation Subscribe My items Reminder »  Archive ~

On the top menu, select the Review tab, then click Check In. This unlocks the item and enables it
to be Published.
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Key Dates

You'll be able to create Key Dates here:

4 & Content
#; Home
4 [y ParklandRegionallibrary
4 [ PRL
P & Home
P D Media
4 5 Dawa
b i Events
» {2l Homepage Banners
b i Festured Events

4 1 Key Dates
F Olds

[#] Remembrance Day

¥ . Special Features
b {2 Tabbed Book Listings
¥ ¢ Two Cards

Key Dates will need to be added and removed as required after they're created in order to show

up on the website.

Create a Key Date

To start, we have to make our Key Date. Right click on your library within the Key Dates folder,

hover on Insert, then click KeyDate.

b ﬂ Homepage Banners

b i Fea Insert 3
4 @ Key 1 Search
FE =
&

El

KeyDate

Give your Key Date a name and click the blue OK button.
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Key Date Fields

-Iimasltring) Date)lime)

o~

Starting Nov 3rd |||December 3, 2023
Didsbury Municipal Library

Satisfaction Survey

1 itlel&

Linkd

Title

Title:

KeyDate

This section should already be filled out with the name you gave it when creating the event.

Link
This is created exactly as the Link on the Homepage Banner

Use Insert link for Sitecore pages, Insert external link for other websites, and Clear to remove
data from the field.

This link will attach to the Title.

Library Tag
You should only see your own library here. Double click it to move it from the All section to the
Selected section. This means it will be available to be Set to your site.
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Date Time
Date Time:

Mo Clear

11/116/2023 b 5:00 PM -

Use the drop-down menu to enter in your desired date. A time is not required.

Time String

Tirne String:

This field can only fit a small amount of text, but can be used as you see fit. It is text that will
appear alongside the date you selected above. Since you can only enter in one date above, I've
sometimes used this field to denote the start of the Key Date and the Date Time as the end.

Check In
Once the Key Date is finished, you'll need to check in the item.

HOME NAVIGATE REVIEW PUBLISH VERSIONS MY TOOLBAR

ll:‘ Q\E/'“. @ [g D‘ You have locked this item. IF_IQ

Save Spelling Markup WValidation Subscribe - My items Reminder =  Archive =

On the top menu, select the Review tab, then click Check In. This unlocks the item and enables it
to be Published.
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Set Your Key Dates

Once you've created your Key Date, you need to add it as an active item.

Under the green Key Dates folder, select your library:

4 i Key Dates
F Olds

[E] KeyDate

[£] Remembrance Day

You'll need to click “Lock and Edit” at the top to enable editing.

You must lock this item before you can edit it.
To lock this itemn, click Edit on the Home tab.

Lock and Edit

Scroll down to this section:

Key Dates:

Al Selected

> - ~ ~
4 {d KeyDates 4 Remembrance Day °
4 Olds
[El KeyDare

[E] Remembrance Day

On the left is all created Key Dates. On the right are Key Dates currently showing on the website.

Double click on each to move them to the opposite section (or use the arrows pointing left and
round found in the middle).

After we're done, it looks like this:

Key Dates:

Al Selected

> o o
4 {3 KeyDates ( :KeyDate Fl
4 Olds
[5] KeyDate

[E] Remembrance Day

When you're done, navigate to the Review tab and click Check In as you did before. Don't forget
to Publish.
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Important Notice
This is a special section here to add highlighted text to the Key Dates section.

Important Notice:

Show editor Suggest fix Edit HTML

[T] Enable Important Notice

Show editor — Works just like the rest of the text editors we've used so far.

Enable Important Notice - this tick box will add and remove the Important Notice from the
website as needed.

Once set, it will appear as a big coloured box under Key Dates:

Important information

All parkland re I libraryLibrary locations will close at
7 pm on Mon, : :

Once you've created all the Key Dates you need, checked them in, added them to the Selected
column, and decided if you need an Important Notice or not, you'll be ready to Publish.
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Special Features
These are found just below Key Dates and are setup in almost exactly the same fashion, with the
addition of an image.

Create a Special Feature
Expand the green Special Features folder, right click on your library, hover on Insert, and click
SpecialFeature.

4 5 Data
b i Events
b '1'_:] Homepage Banners
» @ F Insert b [E| SpecialFeature
4 @K 1 Search
4 [E
4 @S
4 £ Copying b
Sarting 3
¢ Edit

Special Feature Fields
Heading

Heading:

SpecdialFeature

This is the title of your Special Feature and is already filled in with the name we entered when
creating it.

Link
This is created exactly as the Link on the Homepage Banner

Use Insert link for Sitecore pages, Insert external link for other websites, and Clear to remove
data from the field. This link will attach to the Title.
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Special Feature Time & Date

Special Feature Time - Format: 0:00 amfpm, eg. 9:15 am or 10:30 pm
0:00 am

Special Feature Date:

Today Clear

11/15/2023 -

These fields are straightforward. Set the date and time that the Special Feature takes place on.

NOTE: These fields can be left blank and will display nothing on the homepage.

Image
This is the same image selector we used in the Homepage Banner Image section. You should
have already uploaded your image earlier.

Click Browse, then Tree View at the top right, navigate the tree to find your image, and click
Insert to finish. The image should appear in the white box when you're finished.

Library Tag

You should only see your own library here. Double click it to move it from the All section to the
Selected section. This means it will be available to be added to your site, which is covered under
Set Your Special Features.

Event Details
You can add more details to the Special Feature, treating like an event. We haven't been doing
this, instead preferring to just use the Link field to connect to an event we've already created.
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Check In
Once the Special Feature is finished, you'll need to check in the item.

HOME NAVIGATE REVIEW PUBLISH WVERSIONS MY TOOLBAR

l-:‘ AB: @ [g D‘ You have locked this item. i'ﬁ_]@

Save Spelling Markup  Validation Subscribe My items Reminder »  Archive ~

On the top menu, select the Review tab, then click Check In. This unlocks the item and enables it
to be Published.

Set Your Special Features
After you've created your new feature, you'll need to replace one of the active features. Under
the green Special Features folder, click on your library name.

4 ] Special Features

4|75 Olds

[# Check Out Our Mew Books

[#] elibrary Spodight
You'll need to click “Lock and Edit” at the top to enable editing.

You must lock this item before you can edit it.
To lock this item, click Edit on the Home tab.

Lock and Edit

The only section we need to change here is the Special Feature field.

Special Feature:
Select all Deselect al
Al Selected

SpedialFeature b Check Out Qur New Books

< elibrary Spotlight

On the left is all created Special Features. On the right are Special Features currently showing on
the website. Double click on each to move them to the opposite section (or use the arrows
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pointing left and round found in the middle). You can reorder them using the arrows on the far
right, as they display in the list order (biggest feature is at the top).

It's a best practice to make sure you always have three Special Features at any time. If you want
to remove one, but don’t have something to replace it, consider creating a Special Feature that
highlights a section of your website in the interim.

When you're finished, navigate to the Review tab and click the Check In. Don't forget to Publish
the changes.
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Tabbed Book Listings (aka. Book Carousel)

Record Set
Before you can add a section to this feature, you'll need a Bibliographic record set from Polaris.
These will only work that specific type of record set. Once you've got that, you can proceed.

Create a Tabbed Book Listing
Navigate through the tree, expand Tabbed Book Listings, right click on your library, hover on
Insert, then click TabbedBookListing.

4 & Content
& Home
4 [ ParklandRegionallibrary
4 5] PRL
P & Home
P I Media

4 Data

e

P 1 Events Im

» {2 Homepage Banners oH

b @l Featured Events

-

T Key Dates

-

1 Special Features

[

1 Tabbed Book Listings
4 = Old-

Insert » TabbedBookListing

2l Search

Name your new feature with the title of your collection and click OK.
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Heading

Heading:

This is the title that will appear at the top the book carousel. This won't be filled in, so make sure
you type in the title.

Skip the Subheading.

Record Set ID
Record Set ID:

This is where we enter the Bibliographic record set mentioned earlier.

Check In
Once the Tabbed Book Listing is finished, you'll need to check in the item.

HOME NAVIGATE REVIEW PUBLISH VERSIONS MY TOOLBAR

I-:‘ RE- @ [g D‘ You have locked this item. i'ﬁ_]@

Save Spelling Markup  Validation Subscribe My items Reminder »  Archive ~

On the top menu, select the Review tab, then click Check In. This unlocks the item and enables it
to be Published.
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Set Your Tabbed Book Listings
After you've created your new set, you'll need to replace one of the active sets. Under the green

Tabbed Book Listings folder, click on your library name.

4 2 Tabbed Book Listings

F ]

You'll need to click “Lock and Edit” at the top to enable editing.

This section works exactly as it did in settings Key Dates and Special Features.

= Olds

Cozy Romance and Mystery
eBook and eAudio

You must lock this item before you can edit it.
To lock this item, click Edit on the Home tab.

Lock and Edit

Double click the new listing to move it to Selected. It can only contain up to three sets, so also

double click on an old listing to remove it.

When you're done, Check In, and don't forget to Publish.

Page 22 of 28



Two Cards

This aptly named feature is near the bottom of your homepage and can hold up to two cards.
We typically use these to highlight long running or permanent features of the website.

Use your library card to access over 10 million items from over 300 libraries — for free!|

Me Libraries

Create a Two Card

Navigate through the tree, expand Two Cards, right click on your library, hover on Insert, then
click TwoCard.

4 & Content
& Home
4 [ ParklandRegionallibrary
a4 [£] PRL
* & Home
b D Media
4 5 Data
b @ Events
b {3 Homepage Banners
b i Featured Events
b ) Key Dates
b ) Special Features
b {2 Tabbed Book Listings

@ Two Cards

i 5 Insert 3 TwoCard

[

E O Search = TwoCard Folder
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Give the two card a name and click the blue OK button.
Heading
Heading:

TwolCard

This field contains the name we entered when we made the Two Card.

Body
Body:

Show editor Suggest fix Edit HTML

To enter text, double click in the white box or click “Show editor.”
Change and style the text as desired. Probably best not to include hyperlinks or anything fancy.

When you're finished, click the blue Accept button at the bottom right.

Link

Link:

Insert link nsert media link nsert external link Insert anchor nsert nsert JavaScript Follow Clear

m
3

This is created exactly as the Link on the Homepage Banner

Use Insert link for Sitecore pages, Insert external link for other websites, and Clear to remove
data from the field.
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Icon

The icon is a simplistic design mostly for looks to draw the eye. You can choose whatever you
think might be appropriate for the Two Card’s content.

lcom:

Browse

Properties

Open media library Clear Refresh

Click Browse, then Tree View at the top right (just like we did for the Homepage banner)

You'll be able to choose between white and black icons. Expand the colour you want, then select
the Icon you'd like, and click the blue Select button at the bottom right.

Select Media

Upload media

Media items

Media folder: /lcons

4 (] lcons
» 7] Black
4 7] White

activity
airplay
alert-circle
alert-octagon

alert-triangle

align-center

align-justify

align-left

align-right Name: aperture
= Type: Image

archive

arrow-down
arrow-down-circle
arrow-down-left
arrow-down-right
arrow-left
arrow-left-circle
arrow-right
arrow-right-circle

arrow-up

aperture

Dimensions:/sitecore/media li...

o

After this is down, click on the Review tab at the top, the Check In, and you're ready to Publish.
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Featured Events

This is an extra section that doesn't feature on the homepage, but rather your Events calendar.
But, the green folder that hosts this feature is in the same area, so we've included it here.

To begin, expand the green Featured Events folder and click on your library:

4 & Content
%5 Home
4 [ ParklandRegionallibrary
4 [E] PRL
P # Home
P I Media
4 o Data
b i Events
¥ {2 Homepage Banners

4 0 Featured Events

= Olds

Then click Lock and Edit to open the item.

You must lock this item before you can edit it.
To lack this item, click Edit on the Home tab.

Lock and Edit

The only section we need is near the bottom, called Event Selection.

Event Details ~

Event Selection - Selecting the event will override any url in the link field

4 @ Everns

4 @ Olas

4 Adults Seniors

Christmas Ornament Extravaganza
Teens for Laughs
4 @ 2023 Craft Studio

 Adult Scudy Group Basic English Learning

 Banff Center Mountain Film Festival

9 Basic English Learning

All of your library’s events are on the left. On the right are the events that are displayed at the
top of your Event calendar.

They display in rows of three and you can have up to six events.
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Double click on either side to move the item to the other side (or highlight the event and use
the arrows in the middle).

You can also use the up and down arrows at the far right to reorder the events, as they display
in the order listed.

When you're done, navigate to the Review tab at the top and click Check In. With that, make
sure Publish, which is covered in the next section.
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Publishing

The final step after creating, change, or deleting anything with the homepage.

The best practice for publishing sections of the homepage is to select your library under the
section you edited. For example, if you change the Special Features, you'd select here:

4 1 Special Features

4| 5 Olds

[£] Check Out Our New Books
[ elibrary Spotlight
[£] SpecialFeature

Then, navigate to the Publish tab, click the Publish (with the down arrow), then click Publish
item.

HOME NAVIGATE REVIEW PUBLISH VERSIONS MY TOOLBAR

{ &) perience Editor 4. Publishing viewer
View Publishv | % Preview

lish site

- 4. Publish item a . -
—_— _ Cnntent Q

You'll see this window:

Publishing
(®) Smart publish - publish differences between source and target database.

Fublish subitems=
Publish related items ()

Subitems will be everything within the parent folder. Related items are any media or links that
need to accompany the update. In most cases, you'll want to make sure both are selected. Hit
Publish.

Repeat this for any other homepage sections you've edited and you should be done.

As always, if you have any questions or concerns, please contact us at PRL Helpdesk
(helpdesk@prl.ab.ca).
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